Benutzerzahl nach Update von Uraltversion

Fragen zur Installation und zu den ersten Schritten mit WaWision
titusmaximus
Beiträge: 0
Registriert: Fr 1. Dez 2017, 09:01

Benutzerzahl nach Update von Uraltversion

Beitragvon titusmaximus » Fr 1. Dez 2017, 09:29

Hallo,

ich habe eine uralte Version (3.1.x) und versuche ein Update auf eine aktuelle Version.

Das ist erstmal gar nicht erfolgreich gelaufen, da viele Dinge von Hand nachinstalliert werden mussten (iocube-loader, php5.6, mysqli etc.).
Inzwischen kann ich mich am System anmelden, bekomme aber einen weissen Bildschirm.

Bei Angebe einer Fake-wawi-url (http://wawi/index.php?module=dfdf) bekomme ich den Wawision Desktop, allerdings mit einer Fehlermeldung: "Achtung: Die Benutzeranzahl überschreitet die maximale Anzahl von 10", und auf allen Seiten wird die Lizenzvereinbarung angezeigt.

Ich würde die Anzahl der User auch reduzieren, um weitergekommen, aber unter index.php?module=benutzer&action=list
dreht sich nur die Eieruhr.

Gibt es hier eine Empfehlung wie ich weiterkomme?

titusmaximus
Beiträge: 0
Registriert: Fr 1. Dez 2017, 09:01

Re: Benutzerzahl nach Update von Uraltversion

Beitragvon titusmaximus » Fr 1. Dez 2017, 10:05

Ein bischen weiter bin ich noch gekommen:

Die Anzahl der User habe ich direkt in der Mysql Tabelle "User" auf 9 reduziert. Die Fehlermeldung ist weg.

Ich habe dann wie hier im Forum geschrieben ein Update auf cli Ebene gemacht (an das Update im Frontend komme ich nicht dran):
---------------------
root@wawi:/var/www/wawi# php upgradesystemclient2.php
STARTE UPDATE
Im folgenden stehen die Dateien die geaendert wurden.

Erscheinen keine Dateien sind Sie auf der neusten Version.
ENDE UPDATE
root@wawi:/var/www/wawi# php upgradedbonly.php
STARTE DB Upgrade
ENDE DB Upgrade
--------------------
Trotzdem kann ich eigentlich nur die Seite mit den "Grundeinstellungen" besuchen. Alles andere funktioniert nicht.

/index.php?module=welcome&action=start - weisser Bildschirm
/index.php?module=benutzer&action=list - Eieruhr

sauterbe
Administrator
Beiträge: 6
Registriert: Mi 31. Dez 2014, 13:34

Re: Benutzerzahl nach Update von Uraltversion

Beitragvon sauterbe » Fr 1. Dez 2017, 10:19

wenn sie mal eine datei aus pages löschen oder verschieben und dann das update ziehen kommt die datei dann neu?

titusmaximus
Beiträge: 0
Registriert: Fr 1. Dez 2017, 09:01

Re: Benutzerzahl nach Update von Uraltversion

Beitragvon titusmaximus » Fr 1. Dez 2017, 11:24

yepp

# mv kalender.php ../../backup/test/

# php upgradesystemclient2.php
STARTE UPDATE
Im folgenden stehen die Dateien die geaendert wurden.

Erscheinen keine Dateien sind Sie auf der neusten Version.
datei <- ./www/pages/kalender.php
datei ok ./www/pages/kalender.php
ENDE UPDATE

sauterbe
Administrator
Beiträge: 6
Registriert: Mi 31. Dez 2014, 13:34

Re: Benutzerzahl nach Update von Uraltversion

Beitragvon sauterbe » Fr 1. Dez 2017, 19:27

ich habe gerade gesehen da war im update server bei ihnen was falsch / da wurde ausversehen eine iconcube version ausgeliefert obwohl es ja ein account von der open source ist. / bitte nochmal ein Update ziehen. dann sollte alles passen

titusmaximus
Beiträge: 0
Registriert: Fr 1. Dez 2017, 09:01

Re: Benutzerzahl nach Update von Uraltversion

Beitragvon titusmaximus » Di 5. Dez 2017, 18:05

ja, dass ich ein ioncube erhielt und meine 11 User bemängelt wurden hat mich auch gewundert.
ich habe nun in cli Update gemacht.

An meiner Situation (s.o.) ändert das nichts. Es erscheint

- bei Dashboard nur eine weisse Seite
- Einstellungen/Grundeinstellungen ist die einzige Seite die Content hat
- bei den übrigen Seiten dreht die Eieruhr bis Weihnachten

Soll ich noch etwas anderes versuchen?

sauterbe
Administrator
Beiträge: 6
Registriert: Mi 31. Dez 2014, 13:34

Re: Benutzerzahl nach Update von Uraltversion

Beitragvon sauterbe » Do 7. Dez 2017, 06:55

sieht man auf dem webspace irgendwo php fehlermeldungen? im Log hinten herum oder kann man die aktivieren?

titusmaximus
Beiträge: 0
Registriert: Fr 1. Dez 2017, 09:01

Re: Benutzerzahl nach Update von Uraltversion

Beitragvon titusmaximus » Fr 8. Dez 2017, 13:22

Apache log. ein login und nach erfolgreicher anmeldung eine leere seite:
192.168.0.18 - - [08/Dec/2017:14:11:00 +0100] "GET / HTTP/1.1" 200 3011 "-" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.100 Safari/537.36"
192.168.0.18 - - [08/Dec/2017:14:11:00 +0100] "GET /js/jquery-1.7.2.min.js HTTP/1.1" 200 33974 "http://wawi/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.100 Safari/537.36"
192.168.0.18 - - [08/Dec/2017:14:11:07 +0100] "POST / HTTP/1.1" 302 475 "http://wawi/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.100 Safari/537.36"
192.168.0.18 - - [08/Dec/2017:14:11:07 +0100] "GET /index.php?module=welcome&action=start HTTP/1.1" 200 338 "http://wawi/" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.100 Safari/537.36"
192.168.0.18 - - [08/Dec/2017:14:11:08 +0100] "GET /favicon.ico HTTP/1.1" 404 505 "http://wawi/index.php?module=welcome&action=start" "Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.100 Safari/537.36"

mysql.zip enthält das query logging von einem reload der leeren Seite, die das Dashboard zeigen sollte.
Dateianhänge
mysql.zip
(6.94 KiB) 30-mal heruntergeladen

sauterbe
Administrator
Beiträge: 6
Registriert: Mi 31. Dez 2014, 13:34

Re: Benutzerzahl nach Update von Uraltversion

Beitragvon sauterbe » Fr 8. Dez 2017, 15:25

das sind keine PHP meldungen nur Apaxche und MySQL
Sie können auch SSH und Admin account an unsere Mail schicken / dann schauen wir das kurz an